{"action":"Upgrade rustc to 1.22.1+dfsg1-1 or later.","affected":[{"fixed":"1.22.1+dfsg1-1","introduced":"0"}],"component":"rustc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.22.1+dfsg1-1"],"id":"tcs_01M5NCVABGAGHGNE6RMEEZB02Q","modified_at":"2026-10-23T18:03:17.814065957Z","published_at":"2018-08-20T19:31:45.620Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000657","https://security-tracker.debian.org/tracker/CVE-2018-1000657"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1000657#Debian:14/rustc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1000657"}],"summary":"Rust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::colle"}