{"action":"Upgrade cacti to 1.1.37+ds1-1 or later.","affected":[{"fixed":"1.1.37+ds1-1","introduced":"0"}],"component":"cacti","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.1.37+ds1-1"],"id":"tcs_01M5NCVMTDH175WB36YC0E3HRH","modified_at":"2026-10-23T18:02:56.071453062Z","published_at":"2018-04-12T16:29:00.227Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-10059","https://security-tracker.debian.org/tracker/CVE-2018-10059"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-10059","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-10059"}],"summary":"Cacti before 1.1.37 has XSS because the get_current_page function in lib/functions.php relies on $_SERVER['PHP_SELF'] instead of $_SERVER['SCRIPT_NAME'] to determine a page name."}