{"action":"Upgrade mruby to 1.4.0+20180418+git54905e98-1 or later.","affected":[{"fixed":"1.4.0+20180418+git54905e98-1","introduced":"0"}],"component":"mruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.4.0+20180418+git54905e98-1"],"id":"tcs_01M5NCVWJV3QAKGXQRAPJS3TY3","modified_at":"2026-10-23T18:03:18.002440973Z","published_at":"2018-04-17T21:29:00.233Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-10191","https://security-tracker.debian.org/tracker/CVE-2018-10191"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-10191#Debian:13/mruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-10191"}],"summary":"In versions of mruby up to and including 1.4.0, an integer overflow exists in src/vm.c::mrb_vm_exec() when handling OP_GETUPVAR in the presence of deep scope nesting, resulting in a use-after-free. An"}