{"action":"Upgrade mruby to 1.4.0+20180418+git54905e98-1 or later.","affected":[{"fixed":"1.4.0+20180418+git54905e98-1","introduced":"0"}],"component":"mruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.4.0+20180418+git54905e98-1"],"id":"tcs_01M5NCVXT5HR97AHZK5MSXC5PX","modified_at":"2026-10-23T18:02:56.532062847Z","published_at":"2018-04-18T15:29:00.207Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-10199","https://security-tracker.debian.org/tracker/CVE-2018-10199"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-10199","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-10199"}],"summary":"In versions of mruby up to and including 1.4.0, a use-after-free vulnerability exists in src/io.c::File#initilialize_copy(). An attacker that can cause Ruby code to be run can possibly use this to exe"}