{"action":"Upgrade zsh to 5.4.2-4 or later.","affected":[{"fixed":"5.4.2-4","introduced":"0"}],"component":"zsh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.4.2-4"],"id":"tcs_01M5NCWEXK7Q2NEAC2YY93TFFJ","modified_at":"2026-10-23T18:02:56.530600004Z","published_at":"2018-03-09T15:29:00.267Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1071","https://security-tracker.debian.org/tracker/CVE-2018-1071"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1071#Debian:14/zsh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1071"}],"summary":"zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the exec.c:hashcmd() function. A local attacker could exploit this to cause a denial of service."}