{"action":"Upgrade grub to 2.06-r0 or later.","affected":[{"fixed":"2.06-r0","introduced":"0"}],"component":"grub","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["2.06-r0"],"id":"tcs_01M5NCWN47J7GTVCWTPDZ0NH14","modified_at":"2026-10-23T17:17:56.140339081Z","published_at":"2021-03-03T17:15:11.973Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-20225","https://security.alpinelinux.org/vuln/CVE-2021-20225"],"severity":{"label":"medium","score":6.7},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-20225#Alpine:v3.21/grub","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-20225"}],"summary":"A flaw was found in grub2 in versions prior to 2.06. The option parser allows an attacker to write past the end of a heap-allocated buffer by calling certain commands with a large number of specific s"}