{"action":"Upgrade zsh to 5.4.2-4 or later.","affected":[{"fixed":"5.4.2-4","introduced":"0"}],"component":"zsh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.4.2-4"],"id":"tcs_01M5NCWNJD4Y7M5FKG5N8HC833","modified_at":"2026-10-23T18:03:18.212787774Z","published_at":"2018-03-28T13:29:00.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1083","https://security-tracker.debian.org/tracker/CVE-2018-1083"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1083#Debian:14/zsh","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1083"}],"summary":"Zsh before version 5.4.2-test-1 is vulnerable to a buffer overflow in the shell autocomplete functionality. A local unprivileged user can create a specially crafted directory path which leads to code"}