{"action":"Upgrade postgresql to 12.6-r0 or later.","affected":[{"introduced":"13.0"}],"component":"postgresql","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["12.6-r0"],"id":"tcs_01M5NCWQV1TXYMY8SB2VCTD8R3","modified_at":"2026-11-03T06:32:46.371980231Z","published_at":"2021-02-23T18:15:13.473Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-20229","https://security.alpinelinux.org/vuln/CVE-2021-20229"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-20229","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-20229"}],"summary":"A flaw was found in PostgreSQL in versions before 13.2. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table. The highest threat f"}