{"action":"Upgrade libgit2 to 0.27.4+dfsg.1-0.1 or later.","affected":[{"fixed":"0.27.4+dfsg.1-0.1","introduced":"0"}],"component":"libgit2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.27.4+dfsg.1-0.1"],"id":"tcs_01M5NCX29MMHW0WSWH8S3KSA7Q","modified_at":"2026-10-23T18:03:35.649837312Z","published_at":"2018-07-10T14:29:00.323Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-10888","https://security-tracker.debian.org/tracker/CVE-2018-10888"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-10888","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-10888"}],"summary":"A flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use"}