{"action":"Upgrade knot-resolver to 2.4.1-1 or later.","affected":[{"fixed":"2.4.1-1","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.4.1-1"],"id":"tcs_01M5NCX96BXGE43SXDRX2G9EBK","modified_at":"2026-10-23T18:03:53.420582977Z","published_at":"2018-08-02T13:29:00.220Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-10920","https://security-tracker.debian.org/tracker/CVE-2018-10920"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-10920#Debian:14/knot-resolver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-10920"}],"summary":"Improper input validation bug in DNS resolver component of Knot Resolver before 2.4.1 allows remote attacker to poison cache."}