{"action":"Upgrade zsh to 5.5-1 or later.","affected":[{"fixed":"5.5-1","introduced":"0"}],"component":"zsh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.5-1"],"id":"tcs_01M5NCXJJ7Z1MS174P7M5TK8KH","modified_at":"2026-10-23T18:03:18.497845765Z","published_at":"2018-04-11T19:29:01.027Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1100","https://security-tracker.debian.org/tracker/CVE-2018-1100"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1100","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1100"}],"summary":"zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the utils.c:checkmailpath function. A local attacker could exploit this to execute arbitrary code in the context of another"}