{"action":"Upgrade libspf2 to 1.2.10-r5 or later.","affected":[{"fixed":"1.2.10-r5","introduced":"0"}],"component":"libspf2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["1.2.10-r5"],"id":"tcs_01M5NCXR622WRWJFD2WCFQRPJR","modified_at":"2026-10-23T17:17:56.147326757Z","published_at":"2021-08-12T15:15:07.657Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-20314","https://security.alpinelinux.org/vuln/CVE-2021-20314"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-20314#Alpine:v3.17/libspf2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-20314"}],"summary":"Stack buffer overflow in libspf2 versions below 1.2.11 when processing certain SPF macros can lead to Denial of service and potentially code execution via malicious crafted SPF explanation messages."}