{"action":"Upgrade nodejs to 14.16.0-r0 or later.","affected":[{"fixed":"14.16.0-r0","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["14.16.0-r0"],"id":"tcs_01M5NCYBG7XGHC8WV184RCMR9Z","modified_at":"2026-11-03T06:32:31.869001511Z","published_at":"2021-03-03T18:15:14.893Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22883","https://security.alpinelinux.org/vuln/CVE-2021-22883"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22883#Alpine:v3.16/nodejs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22883"}],"summary":"Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of f"}