{"action":"Upgrade nodejs to 14.17.3-r0 or later.","affected":[{"fixed":"14.17.3-r0","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["14.17.3-r0"],"id":"tcs_01M5NCYQPK0KB4VXX2X6HKB2M3","modified_at":"2026-10-23T17:17:56.152317623Z","published_at":"2021-07-12T11:15:07.937Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22918","https://security.alpinelinux.org/vuln/CVE-2021-22918"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22918#Alpine:v3.13/nodejs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22918"}],"summary":"Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether"}