{"action":"Upgrade nodejs to 10.15.0~dfsg-6 or later.","affected":[{"fixed":"10.15.0~dfsg-6","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["10.15.0~dfsg-6"],"id":"tcs_01M5NCZ7HFEY3S94T1676CM8C4","modified_at":"2026-10-15T21:47:28.826805801Z","published_at":"2018-08-21T12:29:00.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-12115","https://security-tracker.debian.org/tracker/CVE-2018-12115"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-12115#Debian:14/nodejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-12115"}],"summary":"In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()`"}