{"action":"Upgrade libspring-java to 4.3.19-1 or later.","affected":[{"fixed":"4.3.19-1","introduced":"0"}],"component":"libspring-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["4.3.19-1"],"id":"tcs_01M5ND0AETTG3MXFF8PDDEKD46","modified_at":"2026-10-09T09:47:27.912724372Z","published_at":"2018-05-11T20:29:00.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-1257","https://security-tracker.debian.org/tracker/CVE-2018-1257"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-1257#Debian:13/libspring-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-1257"}],"summary":"Spring Framework, versions 5.0.x prior to 5.0.6, versions 4.3.x prior to 4.3.17, and older unsupported versions allows applications to expose STOMP over WebSocket endpoints with a simple, in-memory ST"}