{"action":"Upgrade glib to 2.66.7-r0 or later.","affected":[{"introduced":"2.67.0"}],"component":"glib","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["2.66.7-r0"],"id":"tcs_01M5ND29RTN1R1W5NVDX9BX5JF","modified_at":"2026-10-23T17:17:56.164694294Z","published_at":"2021-02-15T17:15:13.073Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-27218","https://security.alpinelinux.org/vuln/CVE-2021-27218"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-27218","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-27218"}],"summary":"An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated mod"}