{"action":"Upgrade glusterfs to 5.1-1 or later.","affected":[{"fixed":"5.1-1","introduced":"0"}],"component":"glusterfs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.1-1"],"id":"tcs_01M5ND32764TJ4W60P46CWA5K8","modified_at":"2026-10-23T18:03:47.670325876Z","published_at":"2018-10-31T19:29:00.533Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-14653","https://security-tracker.debian.org/tracker/CVE-2018-14653"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-14653#Debian:13/glusterfs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-14653"}],"summary":"The Gluster file system through versions 4.1.4 and 3.12 is vulnerable to a heap-based buffer overflow in the '__server_getspec' function via the 'gf_getspec_req' RPC message. A remote authenticated at"}