{"action":"Upgrade squid to 4.15-r0 or later.","affected":[{"fixed":"4.15-r0","introduced":"2.0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["4.15-r0"],"id":"tcs_01M5ND328VB1VEE4CF477TQMDA","modified_at":"2026-10-23T17:17:56.169402111Z","published_at":"2021-05-27T12:15:08.197Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-28651","https://security.alpinelinux.org/vuln/CVE-2021-28651"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-28651","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-28651"}],"summary":"An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to a buffer-management bug, it allows a denial of service. When resolving a request with the urn: scheme, the parser leaks a smal"}