{"action":"Upgrade libvncserver to 0.9.11+dfsg-1.2 or later.","affected":[{"fixed":"0.9.11+dfsg-1.2","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.11+dfsg-1.2"],"id":"tcs_01M5ND3E6ZTYFD9W5R1E2X1DXJ","modified_at":"2026-10-23T18:03:55.231093762Z","published_at":"2018-12-19T16:29:00.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-15126","https://security-tracker.debian.org/tracker/CVE-2018-15126"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-15126#Debian:13/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-15126"}],"summary":"LibVNC before commit 73cb96fec028a576a5a24417b57723b55854ad7b contains heap use-after-free vulnerability in server code of file transfer extension that can result remote code execution"}