{"action":"Upgrade opensc to 0.19.0~rc1-1 or later.","affected":[{"fixed":"0.19.0~rc1-1","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.19.0~rc1-1"],"id":"tcs_01M5ND49F5DQRJT94MECGVMJKR","modified_at":"2026-10-23T18:03:19.678986512Z","published_at":"2018-09-03T14:29:00.513Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-16393","https://security-tracker.debian.org/tracker/CVE-2018-16393"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-16393#Debian:13/opensc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-16393"}],"summary":"Several buffer overflows when handling responses from a Gemsafe V1 Smartcard in gemsafe_get_cert_len in libopensc/pkcs15-gemsafeV1.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supp"}