{"action":"Upgrade opensc to 0.19.0~rc1-1 or later.","affected":[{"fixed":"0.19.0~rc1-1","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.19.0~rc1-1"],"id":"tcs_01M5ND4BAYZYH7NZ00J8KWEPC0","modified_at":"2026-10-23T18:03:00.387789196Z","published_at":"2018-09-04T00:29:00.230Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-16418","https://security-tracker.debian.org/tracker/CVE-2018-16418"],"severity":{"label":"medium","score":6.6},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-16418#Debian:14/opensc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-16418"}],"summary":"A buffer overflow when handling string concatenation in util_acl_to_str in tools/util.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of se"}