{"action":"Upgrade ruby-rack to 1.6.4-6 or later.","affected":[{"fixed":"1.6.4-6","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.6.4-6"],"id":"tcs_01M5ND4J0ZKEV3FSY973VEARCV","modified_at":"2026-10-23T18:03:00.476100576Z","published_at":"2018-11-13T23:29:00.310Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-16471","https://security-tracker.debian.org/tracker/CVE-2018-16471"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-16471","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-16471"}],"summary":"There is a possible XSS vulnerability in Rack before 2.0.6 and 1.6.11. Carefully crafted requests can impact the data returned by the `scheme` method on `Rack::Request`. Applications that expect the s"}