{"action":"Upgrade curl to 7.62.0-1 or later.","affected":[{"fixed":"7.62.0-1","introduced":"0"}],"component":"curl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["7.62.0-1"],"id":"tcs_01M5ND555PZDNK6P1GK8SD807A","modified_at":"2026-10-23T18:03:01.044010108Z","published_at":"2018-10-31T19:29:00.690Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-16842","https://security-tracker.debian.org/tracker/CVE-2018-16842"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-16842#Debian:14/curl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-16842"}],"summary":"Curl versions 7.14.1 through 7.61.1 are vulnerable to a heap-based buffer over-read in the tool_msgs.c:voutf() function that may result in information exposure and denial of service."}