{"action":"Upgrade sudo to 1.9.5p2-r0 or later.","affected":[{"fixed":"1.9.5p2-r0","introduced":"1.8.2"}],"component":"sudo","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["1.9.5p2-r0"],"id":"tcs_01M5ND6GZAENG9X3R9SNP30GYZ","modified_at":"2026-10-23T17:17:56.184541805Z","published_at":"2021-01-26T21:15:12.987Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-3156","https://security.alpinelinux.org/vuln/CVE-2021-3156"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-3156#Alpine:v3.14/sudo","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-3156"}],"summary":"Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via \"sudoedit -s\" and a command-line argument that ends with"}