{"action":"Upgrade perl to 5.28.1-1 or later.","affected":[{"fixed":"5.28.1-1","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.28.1-1"],"id":"tcs_01M5ND6TBYWPYQSJGFPRNJ20C1","modified_at":"2026-10-23T18:03:55.891119083Z","published_at":"2018-12-07T21:29:00.407Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-18311","https://security-tracker.debian.org/tracker/CVE-2018-18311"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-18311#Debian:13/perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-18311"}],"summary":"Perl before 5.26.3 and 5.28.x before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations."}