{"action":"Upgrade perl to 5.28.1-1 or later.","affected":[{"fixed":"5.28.1-1","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.28.1-1"],"id":"tcs_01M5ND6TMXFZ7KWCN8SYX6KGQG","modified_at":"2026-10-23T18:03:02.181035025Z","published_at":"2018-12-05T22:29:00.303Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-18312","https://security-tracker.debian.org/tracker/CVE-2018-18312"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-18312","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-18312"}],"summary":"Perl before 5.26.3 and 5.28.0 before 5.28.1 has a buffer overflow via a crafted regular expression that triggers invalid write operations."}