{"action":"Upgrade squid to 4.15-r0 or later.","affected":[{"fixed":"4.15-r0","introduced":"3.0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["4.15-r0"],"id":"tcs_01M5ND6WBZQQPCB4YAPDKPKMW4","modified_at":"2026-10-23T17:17:56.185997529Z","published_at":"2021-06-08T20:15:09.057Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-31807","https://security.alpinelinux.org/vuln/CVE-2021-31807"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-31807#Alpine:v3.11/squid","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-31807"}],"summary":"An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. An integer overflow problem allows a remote server to achieve Denial of Service when delivering responses to HTTP Range requests. The"}