{"action":"Upgrade squid to 4.15-r0 or later.","affected":[{"introduced":"5.0"}],"component":"squid","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["4.15-r0"],"id":"tcs_01M5ND6YTTJWAS2E5CGESJ5XRY","modified_at":"2026-10-23T17:17:56.186176151Z","published_at":"2021-05-27T14:15:07.500Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-31808","https://security.alpinelinux.org/vuln/CVE-2021-31808"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-31808","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-31808"}],"summary":"An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to an input-validation bug, it is vulnerable to a Denial of Service attack (against all clients using the proxy). A client sends"}