{"action":"Upgrade uriparser to 0.9.0-1 or later.","affected":[{"fixed":"0.9.0-1","introduced":"0"}],"component":"uriparser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.0-1"],"id":"tcs_01M5ND8B09CCGRK8SGV2817NFH","modified_at":"2026-10-23T18:03:03.894071880Z","published_at":"2018-11-12T15:29:00.227Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-19198","https://security-tracker.debian.org/tracker/CVE-2018-19198"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-19198#Debian:14/uriparser","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-19198"}],"summary":"An issue was discovered in uriparser before 0.9.0. UriQuery.c allows an out-of-bounds write via a uriComposeQuery* or uriComposeQueryEx* function because the '&' character is mishandled in certain con"}