{"action":"Upgrade uriparser to 0.9.0-1 or later.","affected":[{"fixed":"0.9.0-1","introduced":"0"}],"component":"uriparser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.0-1"],"id":"tcs_01M5ND8B7VCZQSCYZD8GYG8P5H","modified_at":"2026-10-23T18:03:03.908555381Z","published_at":"2018-11-12T15:29:00.287Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-19199","https://security-tracker.debian.org/tracker/CVE-2018-19199"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-19199#Debian:13/uriparser","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-19199"}],"summary":"An issue was discovered in uriparser before 0.9.0. UriQuery.c allows an integer overflow via a uriComposeQuery* or uriComposeQueryEx* function because of an unchecked multiplication."}