{"action":"Upgrade libgcrypt to 1.9.4-r0 or later.","affected":[{"fixed":"1.9.4-r0","introduced":"1.9.0"}],"component":"libgcrypt","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["1.9.4-r0"],"id":"tcs_01M5ND8E8HCQS999RFGX8KA9JC","modified_at":"2026-10-23T17:17:56.190711573Z","published_at":"2021-06-08T11:15:07.767Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-33560","https://security.alpinelinux.org/vuln/CVE-2021-33560"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-33560#Alpine:v3.14/libgcrypt","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-33560"}],"summary":"Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appr"}