{"action":"Upgrade ruby to 3.1.3-r0 or later.","affected":[{"fixed":"3.1.3-r0","introduced":"2.7.0"}],"component":"ruby","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["3.1.3-r0"],"id":"tcs_01M5ND8JJPRJ5XT3V69K7E92N2","modified_at":"2026-10-23T17:17:56.190930842Z","published_at":"2022-11-18T23:15:18.987Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-33621","https://security.alpinelinux.org/vuln/CVE-2021-33621"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-33621#Alpine:v3.17/ruby","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-33621"}],"summary":"The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTT"}