{"action":"Upgrade libspf2 to 1.2.11-r0 or later.","affected":[{"fixed":"1.2.11-r0","introduced":"0"}],"component":"libspf2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.17","exploited":false,"fixed_versions":["1.2.11-r0"],"id":"tcs_01M5ND8MEKB7FXNPN0G9KA6X50","modified_at":"2026-10-23T17:17:56.191314506Z","published_at":"2022-01-19T18:15:07.783Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-33912","https://security.alpinelinux.org/vuln/CVE-2021-33912"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-33912#Alpine:v3.17/libspf2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-33912"}],"summary":"libspf2 before 1.2.11 has a four-byte heap-based buffer overflow that might allow remote attackers to execute arbitrary code (via an unauthenticated e-mail message from anywhere on the Internet) with"}