{"action":"Upgrade xorg-server to 1.20.10-r1 or later.","affected":[{"fixed":"1.20.10-r1","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["1.20.10-r1"],"id":"tcs_01M5ND9EQZEA8HTKZ20DRJ416P","modified_at":"2026-10-23T17:17:56.194479366Z","published_at":"2021-04-26T15:15:07.857Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-3472","https://security.alpinelinux.org/vuln/CVE-2021-3472"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-3472#Alpine:v3.12/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-3472"}],"summary":"A flaw was found in xorg-x11-server in versions before 1.20.11. An integer underflow can occur in xserver which can lead to a local privilege escalation. The highest threat from this vulnerability is"}