{"action":"Upgrade libvncserver to 0.9.11+dfsg-1.2 or later.","affected":[{"fixed":"0.9.11+dfsg-1.2","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.11+dfsg-1.2"],"id":"tcs_01M5ND9SSF61N9WQFEDHGSXQKX","modified_at":"2026-10-23T18:03:04.473041697Z","published_at":"2018-12-19T16:29:00.343Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20019","https://security-tracker.debian.org/tracker/CVE-2018-20019"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20019#Debian:14/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20019"}],"summary":"LibVNC before commit a83439b9fbe0f03c48eb94ed05729cb016f8b72f contains multiple heap out-of-bound write vulnerabilities in VNC client code that can result remote code execution"}