{"action":"Upgrade libvncserver to 0.9.11+dfsg-1.2 or later.","affected":[{"fixed":"0.9.11+dfsg-1.2","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.11+dfsg-1.2"],"id":"tcs_01M5ND9T0M7XVNJN0C3HWRBY18","modified_at":"2026-10-23T18:03:05.347829303Z","published_at":"2018-12-19T16:29:00.373Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20020","https://security-tracker.debian.org/tracker/CVE-2018-20020"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20020#Debian:13/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20020"}],"summary":"LibVNC before commit 7b1ef0ffc4815cab9a96c7278394152bdc89dc4d contains heap out-of-bound write vulnerability inside structure in VNC client code that can result remote code execution"}