{"action":"Upgrade libvncserver to 0.9.11+dfsg-1.2 or later.","affected":[{"fixed":"0.9.11+dfsg-1.2","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.11+dfsg-1.2"],"id":"tcs_01M5ND9V45AQ70FSP216G4G6GC","modified_at":"2026-10-23T18:03:05.144041650Z","published_at":"2018-12-19T16:29:00.420Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20021","https://security-tracker.debian.org/tracker/CVE-2018-20021"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20021","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20021"}],"summary":"LibVNC before commit c3115350eb8bb635d0fdb4dbbb0d0541f38ed19c contains a CWE-835: Infinite loop vulnerability in VNC client code. Vulnerability allows attacker to consume excessive amount of resources"}