{"action":"Upgrade haproxy to 1.8.15-1 or later.","affected":[{"fixed":"1.8.15-1","introduced":"0"}],"component":"haproxy","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.8.15-1"],"id":"tcs_01M5NDA2SKRBZKW70KWZ1BF4XS","modified_at":"2026-10-23T18:03:56.502903044Z","published_at":"2018-12-12T17:29:00.247Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20102","https://security-tracker.debian.org/tracker/CVE-2018-20102"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20102#Debian:14/haproxy","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20102"}],"summary":"An out-of-bounds read in dns_validate_dns_response in dns.c was discovered in HAProxy through 1.8.14. Due to a missing check when validating DNS responses, remote attackers might be able read the 16 b"}