{"action":"Upgrade libextractor to 1:1.8-2 or later.","affected":[{"fixed":"1:1.8-2","introduced":"0"}],"component":"libextractor","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1:1.8-2"],"id":"tcs_01M5NDAQH6ZZ5DFN059W1D1D6H","modified_at":"2026-10-23T18:03:56.786835159Z","published_at":"2018-12-24T05:29:01.600Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20431","https://security-tracker.debian.org/tracker/CVE-2018-20431"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20431#Debian:13/libextractor","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20431"}],"summary":"GNU Libextractor through 1.8 has a NULL Pointer Dereference vulnerability in the function process_metadata() in plugins/ole2_extractor.c."}