{"action":"Upgrade libvncserver to 0.9.11+dfsg-1.3 or later.","affected":[{"fixed":"0.9.11+dfsg-1.3","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.11+dfsg-1.3"],"id":"tcs_01M5NDBCKK12QQ6AWY82J8GVC7","modified_at":"2026-10-23T18:03:05.334645182Z","published_at":"2019-01-30T18:29:00.410Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20749","https://security-tracker.debian.org/tracker/CVE-2018-20749"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20749","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20749"}],"summary":"LibVNC before 0.9.12 contains a heap out-of-bounds write vulnerability in libvncserver/rfbserver.c. The fix for CVE-2018-15127 was incomplete."}