{"action":"Upgrade openjpeg2 to 2.3.1-1 or later.","affected":[{"fixed":"2.3.1-1","introduced":"0"}],"component":"openjpeg2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.3.1-1"],"id":"tcs_01M5NDBKWCFFC8239KQHESR0HZ","modified_at":"2026-10-23T18:03:05.586168141Z","published_at":"2019-06-26T18:15:10.010Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20846","https://security-tracker.debian.org/tracker/CVE-2018-20846"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20846","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20846"}],"summary":"Out-of-bounds accesses in the functions pi_next_lrcp, pi_next_rlcp, pi_next_rpcl, pi_next_pcrl, pi_next_rpcl, and pi_next_cprl in openmj2/pi.c in OpenJPEG through 2.3.0 allow remote attackers to cause"}