{"action":"Upgrade openjpeg2 to 2.3.1-1 or later.","affected":[{"fixed":"2.3.1-1","introduced":"0"}],"component":"openjpeg2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.3.1-1"],"id":"tcs_01M5NDBMA09SCXKM04V9K4EM8A","modified_at":"2026-10-23T18:03:05.457174157Z","published_at":"2019-06-26T18:15:10.057Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20847","https://security-tracker.debian.org/tracker/CVE-2018-20847"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20847#Debian:13/openjpeg2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20847"}],"summary":"An improper computation of p_tx0, p_tx1, p_ty0 and p_ty1 in the function opj_get_encoding_parameters in openjp2/pi.c in OpenJPEG through 2.3.0 can lead to an integer overflow."}