{"action":"Upgrade linux to 4.16.5-1 or later.","affected":[{"fixed":"4.16.5-1","introduced":"0"}],"component":"linux","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.16.5-1"],"id":"tcs_01M5NDBP01MZX776W5TVE515T4","modified_at":"2026-10-23T18:03:05.793896424Z","published_at":"2019-08-07T15:15:11.970Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20961","https://security-tracker.debian.org/tracker/CVE-2018-20961"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20961","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20961"}],"summary":"In the Linux kernel before 4.16.4, a double free vulnerability in the f_midi_set_alt function of drivers/usb/gadget/function/f_midi.c in the f_midi driver may allow attackers to cause a denial of serv"}