{"action":"Upgrade patch to 2.7.6-5 or later.","affected":[{"fixed":"2.7.6-5","introduced":"0"}],"component":"patch","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.7.6-5"],"id":"tcs_01M5NDBPKJP3GVWSNCD6JVVTPH","modified_at":"2026-10-23T18:03:05.904395292Z","published_at":"2019-08-16T04:15:09.860Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-20969","https://security-tracker.debian.org/tracker/CVE-2018-20969"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-20969#Debian:14/patch","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-20969"}],"summary":"do_ed_script in pch.c in GNU patch through 2.7.6 does not block strings beginning with a ! character. NOTE: this is the same commit as for CVE-2019-13638, but the ! syntax is specific to ed, and is un"}