{"action":"Upgrade apache2 to 2.4.49-r0 or later.","affected":[{"fixed":"2.4.49-r0","introduced":"0"}],"component":"apache2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["2.4.49-r0"],"id":"tcs_01M5NDEBHWWK8HT2FZF2FVVXKG","modified_at":"2026-10-23T17:17:56.210692093Z","published_at":"2021-09-16T15:15:07.633Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-40438","https://security.alpinelinux.org/vuln/CVE-2021-40438"],"severity":{"label":"critical","score":9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-40438#Alpine:v3.18/apache2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-40438"}],"summary":"A crafted request uri-path can cause mod_proxy to forward the request to an origin server choosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier."}