{"action":"Upgrade libgcrypt to 1.8.8-r1 or later.","affected":[{"fixed":"1.8.8-r1","introduced":"0"}],"component":"libgcrypt","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["1.8.8-r1"],"id":"tcs_01M5NDEEEX4QHYCEBEJ3HTTVGY","modified_at":"2026-10-23T17:17:56.210749993Z","published_at":"2021-09-06T19:15:07.587Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-40528","https://security.alpinelinux.org/vuln/CVE-2021-40528"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-40528","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-40528"}],"summary":"The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by"}