{"action":"Upgrade pycryptodome to 3.4.11-1 or later.","affected":[{"fixed":"3.4.11-1","introduced":"0"}],"component":"pycryptodome","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.4.11-1"],"id":"tcs_01M5NDG7AXKY02ME53BQ4Y1N23","modified_at":"2026-10-23T18:03:48.565620664Z","published_at":"2018-02-03T15:29:00.653Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-6594","https://security-tracker.debian.org/tracker/CVE-2018-6594"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-6594#Debian:14/pycryptodome","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-6594"}],"summary":"lib/Crypto/PublicKey/ElGamal.py in PyCrypto through 2.6.1 generates weak ElGamal key parameters, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not ha"}