{"action":"Upgrade freerdp2 to 2.0.0~git20181120.1.e21b72c95+dfsg1-1 or later.","affected":[{"fixed":"2.0.0~git20181120.1.e21b72c95+dfsg1-1","introduced":"0"}],"component":"freerdp2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.0.0~git20181120.1.e21b72c95+dfsg1-1"],"id":"tcs_01M5NDJCNNWKV0GV046WA4P7NE","modified_at":"2026-10-23T18:03:09.475803099Z","published_at":"2018-11-29T18:29:00.990Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2018-8788","https://security-tracker.debian.org/tracker/CVE-2018-8788"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2018-8788","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2018-8788"}],"summary":"FreeRDP prior to version 2.0.0-rc4 contains an Out-Of-Bounds Write of up to 4 bytes in function nsc_rle_decode() that results in a memory corruption and possibly even a remote code execution."}