{"action":"Upgrade nginx to 1.20.2-r2 or later.","affected":[{"fixed":"1.20.2-r2","introduced":"0"}],"component":"nginx","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.20.2-r2"],"id":"tcs_01M5NDK2D8Y7Q7ZNTCF2MPVTTN","modified_at":"2026-10-23T17:17:56.231086642Z","published_at":"2022-02-14T22:15:07.757Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-46462","https://security.alpinelinux.org/vuln/CVE-2021-46462"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-46462#Alpine:v3.24/nginx","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-46462"}],"summary":"njs through 0.7.1, used in NGINX, was discovered to contain a segmentation violation via njs_object_set_prototype in /src/njs_object.c."}